Pepperdine IT Supports macOS High Sierra

January 30, 2018

Pepperdine IT now supports the latest Mac Operating System, OS X 10.13.3, also known as High Sierra. Before upgrading your operating system, please ensure that your Mac meets the following requirements:

General Requirements

• OS X 10.8 or newer
• Minimum of 2 GB of RAM
• Minimum of 15 GB of available hard drive space

Mac Hardware Requirements

• MacBook (late 2009 or newer)
• MacBook Pro (mid 2010 or newer)
• MacBook Air (Late 2010 or newer)
• Mac mini (mid 2010 or newer)
• iMac (late 2009 or newer)
• Mac Pro (mid 2010 or newer)

Software Compatibility Requirements

• Apps should be compatible with macOS High Sierra 10.13.3
• The Roaring Apps website provides a matrix of software compatible with Mac OS X 10.9 - 10.13

Application Currently Not Supported

• Symantec Endpoint Encryption (PGP)

If you are using this encryption method, you will have to wait until the products support macOS High Sierra before upgrading your Mac. Please consult your local IT support representative, or complete a Technology Request Form.

If you would like to upgrade to the latest Mac OS, please contact your local IT support representative, visit your local graduate campus support team, or complete a Technology Request Form. Questions or comments? Please contact Pepperdine IT Service Desk.

IT Service Desk

Have A Suggestion for IT?

Click to share your suggestion, anonymously if preferred, to improve Pepperdine IT.